Ubuntu 15.04中应用Eclipse 4.4、Java 8以及WTP

阅读目录

Ubuntu 15.04中的Eclipse 4.4

  在前一篇中
http://www.linuxidc.com/Linux/2015-04/116735.htm,我发现了
Ubuntu 15.04 中的新工具 Ubuntu Make,同时发现了在 Ubuntu 15.04 中使用
Eclipse 4.4 的方法。有人可能会说,要使用 Eclipse 4.4,直接从 Eclipse
的官网下载不就行了吗?但是在 Ubuntu 中,官网下载的 Eclipse 和 Ubuntu
自带的 Eclipse 有点不一样。我觉得 Ubuntu 中的 Eclipse
是修改过外观的,其整个色调都是偏红色的,用着很舒服,而官网下载的 Eclipse
色调是偏蓝色的。看我后面的截图就知道了。

  以前我都是使用 Ubuntu 软件源中的 Eclipse,使用命令
sudo aptitude install eclipse 就可以安装,安装 Eclipse
的时候会自动安装 openjdk-7。但是 Ubuntu 软件源中的 Eclipse 一直都是 3.8
版,我都等几年了,也不见升级。直到我发现 Ubuntu
Make,试用它的时候,才发现 Eclipse 4.4 藏在这里。(试用 Ubuntu Make
还可以下载好多其它的 IDE,具体内容请看我上一篇随笔。)

  下载和安装 Eclipse 4.4 很简单,现在使用这个命令:
umake ide eclipse。而且这个命令不需要超级用户的权限,下载的 Eclipse
在当前用户的主目录中。安装完成后 Eclipse
的图标自动出现在桌面左侧的启动器中,这时的 Eclipse 还是 pure
的,其它的插件都需要自己安装。

  • Ubuntu
    15.04中的Eclipse 4.4
  • 拥抱Java 8
  • 永利澳门游戏网站,Eclipse 4.4中的Web开发环境
  • 预览功能需要libwebkitgtk-1.0-0,否则会出错

拥抱Java 8

  Ubuntu 15.04 默认的 Java 版本还是 openjdk-7,为了让 Eclipse
运行更稳定以及使用 Java 8 的一些新特性,还是要升级到 openjdk-8。Ubuntu
15.04 的软件源中有 openjdk-8,使用下面命令安装即可:

sudo aptitude install openjdk-8-jdk
sudo aptitude install openjdk-8-jre
sudo aptitude install openjdk-8-jre-headless

  安装完成后,系统自动将默认的 Java 版本切换为 Java 8。如下图:
永利澳门游戏网站 1

  如果要在 Java 7 和 Java 8 之间切换,可以使用如下命令:

sudo update-alternatives --config java

Ubuntu 15.04中的Eclipse 4.4

  在前一篇中(http://www.linuxidc.com/Linux/2015-04/116735.htm),我发现了
Ubuntu 15.04 中的新工具 Ubuntu Make,同时发现了在 Ubuntu 15.04 中使用
Eclipse 4.4 的方法。有人可能会说,要使用 Eclipse 4.4,直接从 Eclipse
的官网下载不就行了吗?但是在 Ubuntu 中,官网下载的 Eclipse 和 Ubuntu
自带的 Eclipse 有点不一样。我觉得 Ubuntu 中的 Eclipse
是修改过外观的,其整个色调都是偏红色的,用着很舒服,而官网下载的 Eclipse
色调是偏蓝色的。看我后面的截图就知道了。

  以前我都是使用 Ubuntu 软件源中的 Eclipse,使用命令
sudo aptitude install eclipse 就可以安装,安装 Eclipse
的时候会自动安装 openjdk-7。但是 Ubuntu 软件源中的 Eclipse 一直都是 3.8
版,我都等几年了,也不见升级。直到我发现 Ubuntu
Make,试用它的时候,才发现 Eclipse 4.4 藏在这里。(试用 Ubuntu Make
还可以下载好多其它的
IDE,具体内容请看我上一篇随笔。)

  下载和安装 Eclipse 4.4 很简单,现在使用这个命令:
umake ide eclipse。而且这个命令不需要超级用户的权限,下载的 Eclipse
在当前用户的主目录中。安装完成后 Eclipse
的图标自动出现在桌面左侧的启动器中,这时的 Eclipse 还是 pure
的,其它的插件都需要自己安装。

Eclipse 4.4中的Web开发环境

  前面说过,刚安装的 Eclipse 4.4 是 pure 的。要开发 Web 应用,靠的是
Java EE 插件,如下图:
永利澳门游戏网站 2
  反正我是把这一个分类中的所有插件都安装了,艺多不压身嘛。安装了这些插件后,写
HTML、CSS、JavaScript 的工具都有了,甚至连开发 PHP
的环境也有了,虽然我不写 PHP 程序。

  专业的前端攻城狮大多使用
WebStorm,这个工具我也下载试用了。见我上一篇随笔。我仍然还是习惯使用
Eclipse 的 Web 开发插件。其实 Eclipse 中的 Web
工具已经很老旧了,貌似还不支持HTML5、CSS3和Javascript
5,我是无力吐槽啊。下面,写个 Bootstrap 的例子测试一下,如下图:
永利澳门游戏网站 3

  左边是项目的文件组成,中间是 Web Page
编辑器,有代码视图和设计视图。我这里的代码是从 Bootstrap
的示例中复制过来的,展示了 Bootstrap 的默认 theme 的效果。右边是 Outline
视图,这个我不多说。 Web Page 编辑器还有预览功能,如下图:
永利澳门游戏网站 4

  预览效果并不好,可能是因为 Eclipse 使用的 Webkit
版本太低了吧。不过可以在外部浏览器中打开该页面进行预览,下图是 FireFox
中的效果:
永利澳门游戏网站 5

回到顶部

发表评论

电子邮件地址不会被公开。 必填项已用*标注