server报依赖错误的解决方法,server报依赖错误的完美解决方法

ubuntu安装openssh-server报依赖错误的消除措施,

主题素材:系统重装后,安装和构造SSH,防火墙配置

系统景况

Linux user #50~14.04.1-Ubuntu SMP Wed Jul 13 01:06:37 UTC 2016 i686 i686 i686 GNU/Linux
#安装install openssh-server
sudo apt install openssh-server -y

报错难点

实施以下命令安装openssh-server:

sudo apt-get install openssh-server

小编并不曾安装成功,而且吸收接纳如下提醒:

下列软件包有未满足的依赖关系:
 openssh-server : 依赖: openssh-client (= 1:6.6p1-2ubuntu1) 但是 1:6.6p1-2ubuntu2.7 正要被安装
                  推荐: ncurses-term 但是它将不会被安装
                  推荐: ssh-import-id 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

图片 1

碰着难题:

消除方式

那是因为,openssh-server是依据于openssh-clien的,这ubuntu不是自带了openssh-client吗?原由是自带的openssh-clien与所要安装的openssh-server所信任的版本分歧,这里所依赖的本子是1:6.6p1-2ubuntu1

故此要设置相应版本的openssh-clien,来掩瞒掉ubuntu自带的openssh-clien:

$ sudo apt-get install openssh-client=1:6.6p1-2ubuntu1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
建议安装的软件包:
  libpam-ssh keychain monkeysphere
下列软件包将被【降级】:
  openssh-client
升级了 0 个软件包,新安装了 0 个软件包,降级了 1 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 577 kB 的软件包。
解压缩后将会空出 5,120 B 的空间。
您希望继续执行吗? [Y/n] y
获取:1 http://mirrors.aliyun.com/ubuntu/ trusty/main openssh-client i386 1:6.6p1-2ubuntu1 [577 kB]
下载 577 kB,耗时 0秒 (850 kB/s)       
dpkg:警告:即将把 openssh-client 从 1:6.6p1-2ubuntu2.7 降级到 1:6.6p1-2ubuntu1
(正在读取数据库 ... 系统当前共安装有 171781 个文件和目录。)
正准备解包 .../openssh-client_1%3a6.6p1-2ubuntu1_i386.deb  ...
正在将 openssh-client (1:6.6p1-2ubuntu1) 解包到 (1:6.6p1-2ubuntu2.7) 上 ...
正在处理用于 man-db (2.6.7.1-1ubuntu1) 的触发器 ...
正在设置 openssh-client (1:6.6p1-2ubuntu1) ...

覆盖安装实行到位之后,再度安装openssh-server就i能够成功安装了:

图片 2

运用ps命令查找ssh的类别经过,找到sshd表达安装成功:

$ ps -e | grep ssh
4723 ?        00:00:00 sshd

系统情况 Linux user #50~14.04.1-Ubuntu SMP Wed Jul 13 01:06:37 UTC 二〇一六i686 i686 i686 GNU/Linux 报错难题 试行以…

sudo apt install openssh-server -y

正在读取软件包列表… 完结

正在解析软件包的借助关系树

正值读取状态音信… 达成

有风姿洒脱对软件包没办法被安装。假使您用的是 unstable 发行版,那也许是

因为系统不可能直达你必要的动静形成的。该版本中或许会有部分您供给的软件

包尚未被创制或然它们已被从新到(Incoming卡塔尔(英语:State of Qatar)目录移出。

下列新闻也许会对消除难题负有利于:

下列软件包有未满意的信任关系:

openssh-server : 依赖: openssh-client (= 1:7.1p1-4)

依附: openssh-sftp-server 不过它将不会被设置

引入: ssh-import-id 然则它将不会被设置

E:
不可能修改错误,因为您须求有些软件包保持现状,正是它们破坏了软件包间的信赖关系。

赶尽杀绝办法:

ubuntu自带的有openssh-client,所以能够通过

ssh username@host

来远程连接linux

但是要想经过ssh被接二连三,ubuntu系统供给有openssh-server,能够经过

ps -e | grep ssh

来查阅,若无突显sshd则证实没有设置openssh-server

可通过

sudo apt-get install openssh-server

来设置openssh-server,若是顺遂的话会安装成功,倘若碰着

$ sudo apt install openssh-server -y

正值读取软件包列表… 完毕

正在剖析软件包的依附关系树

正在读取状态音信… 完结

发表评论

电子邮件地址不会被公开。 必填项已用*标注